PROMOÇÃO - Magazine Luiza - NÃO PERCA!

Encontre no blog...

02/04/2016

Excel - Como contar o número de vezes que um item aparece em uma lista

Excel - Como contar o número de vezes que um item aparece em uma lista - Visual Dicas

Função CONT.SE do Excel

Se você possui uma lista extensa e precisa contar o número de vezes que um determinado nome ou número aparece nela, poderá usar apenas uma função simples do software Microsoft Excel. Neste artigo vamos mostrar como utilizar a função CONT.SE para contar itens de uma lista sem precisar recorrer a macros ou operações trabalhosas de ordenação.

Observação: A função CONT.SE só é válida se você estiver utilizando o Excel no idioma Português - Brasil (pt_BR). Se você estiver utilizando o Excel no idioma Português - Portugal (pt-PT), substitua a função por CONTAR.SE.

 

Sintaxe da função CONT.SE do Excel

Para utilizar a função CONT.SE é importante conhecer primeiro a sintaxe da função:

CONT.SE(intervalo; critério)

Intervalo (obrigatório) --> O grupo de células que pretende contar, ou seja, define a lista que se deseja contar. O intervalo pode conter números, matrizes, um intervalo com nome ou referências que contêm números.

Critério (obrigatório) --> Um número, expressão, referência de célula ou cadeia de texto que determina quais células serão contadas.

Usando a função CONT.SE do Excel

Para melhor compreensão vamos demonstrar os recursos da função CONT.SE através de exemplos:

Abra uma nova planilha no Excel (qualquer versão) e digite os dados conforme imagem abaixo:

Excel - Como contar o número de vezes que um item aparece em uma lista - Visual Dicas

Através da planilha de exemplo acima vamos extrair algumas possibilidades para o uso da função CONT.SE, como sendo:

a) Conta o número de vezes que um texto alfanumérico aparece em uma lista

Exemplo - Número de venda de lápis:  Função utilizada =CONT.SE(B2:B20;"lápis")

Observe que a função retornou o valor 4, ou seja a palavra “lápis” apareceu 4 vezes no intervalo das células B2 até B20.

Atenção: Toda palavra (texto alfanumérico) que se deseja contar deve estar entre aspas.

image

b) Conta o número de vezes que um número aparece em uma lista

Exemplo - venda de mercadorias com valor unitário de R$ 12,00: 

Função utilizada  =CONT.SE(C2:C20;12)

Observe que após aplicada a função na célula E24, obtivemos o valor 5, ou seja, o número 12 apareceu 5 vezes no intervalo de células entre C2 e C20.

Atenção: Não utilizar aspas para valores numéricos.

Excel - Como contar o número de vezes que um item aparece em uma lista - Visual Dicas

c) Conta o número de vezes que uma operação lógica aparece em uma lista

Exemplo: venda quantidades com 150 ou mais itens

Função utilizada  =CONT.SE(D2:D20;”>=150”)

Atenção: Toda expressão lógica que se deseja contar deve estar entre aspas.

Excel - Como contar o número de vezes que um item aparece em uma lista - Visual Dicas

Exemplo: venda onde o valor total está entre R$ 1.500 e R$ 3.000,00

Função utilizada =CONT.SE(E2:E20;">1500")-CONT.SE(E2:E20;">=3000")

Excel - Como contar o número de vezes que um item aparece em uma lista - Visual Dicas

d) Conta o número de vezes que o valor de uma célula aparece em uma lista

Exemplo: Número de venda de livros (célula B20) 

Função utilizada =CONT.SE(B2:E20;B20)

Excel - Como contar o número de vezes que um item aparece em uma lista - Visual Dicas

Usando caracteres “curinga” na função CONT.SE

Vamos mostrar dois recursos utilizados com caracteres tipo “curinga” do Excel. Abra uma outra planilha no Excel (qualquer versão) e digite os dados conforme nosso exemplo abaixo:

image

a) Identificando se é texto (string) ou um valor numérico

O asterisco ( * ) pode ser usado como curinga que corresponde a qualquer caractere alfanumérico, ou seja, identifica se o valor da célula é um texto ou um número.

Atenção: O asterisco deve estar entre aspas.

Exemplo: Conta quantas células possuem caracteres de texto no intervalo B2:B8 cujo o retorno é 3.

Função utilizada =CONT.SE(B2:B8;"*")

image

b) Identificando o número de caracteres de um texto

O ponto de interrogação ( ? ) pode ser usado como curinga que corresponde a qualquer caractere individual.

Atenção: o(s) caractere(s) ponto de interrogação deve(m) estar entre aspas.

Exemplo: Identificar quantas vezes aparece a palavra menino, ou seja, quantas vezes palavras com 4 caracteres mais final “no” aparecem no intervalo A2:A8.

Função utilizada =CONT.SE(A2:A8;"????no")

image

Exemplo: No exemplo a seguir vamos contar quantos nomes possuem 6 caracteres, onde usaremos 6 vezes o ponto de interrogação como uma expressão.

Função utilizada =CONT.SE(C2:C8;"??????")

image

Para saber mais sobre a função =CONT.SE acesse o link: Suporte Microsoft Office

byALF

0 comentários:

Postar um comentário

Gostou do Post? Então espalhe!

Quem está curtindo...

Encontre no blog...

Gostou? Então espalhe!

Twitter Delicious Facebook Digg Stumbleupon Favorites More